Ridge Gourd - no female flowers | Vegetable gardening | Urban Gardening, Terrace gardening and Hydroponics

Share this with your garden buddies:
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Ridge Gourd - no female flowers
Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 (0 votes) 
Avatar
zaftab
New Member
Members
September 2, 2014 - 10:19 am
Member Since: September 2, 2014
Forum Posts: 1
sp_UserOfflineSmall Offline

Hello,

I am seeking some advice on a situation that I am facing. I have a ridge gourd (tori) vine spread over 15 - 20 ft. Its about 90 days old and has been producing a lot of male flowers. So far, I havent seen any female flower on the plant. Is it possible that this palnt will not produce any female flowers? is there something that I am missing? Please let me know.

thanks,

Zee

Share this with your garden buddies:
Avatar
Srikanth
Serilingampally, Hyderabad
Moderator
Members

Moderators
September 2, 2014 - 2:06 pm
Member Since: October 27, 2010
Forum Posts: 368
sp_UserOfflineSmall Offline

You can try spraying Boron.

Share this with your garden buddies:

Thanks,

Srikanth

Forum Timezone: Asia/Kolkata

Most Users Ever Online: 134

Currently Online:
17 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Satish: 186

snorkel4u: 147

raghu: 104

premlatha18: 94

shweta: 89

Jay: 87

Member Stats:

Guest Posters: 143

Members: 3603

Moderators: 1

Admins: 1

Forum Stats:

Groups: 3

Forums: 17

Topics: 1216

Posts: 5642

Newest Members:

Richardsob, RickyMof, Mopinweep, Dynnochkapit, DanielShure, 9Bala9, Byronmor, michealnx11, paku99, yvonnefj16, alllawer, AndreyDox, Williedyday, EvgenFlunc, nicolegb1

Moderators: Srikanth: 368

Administrators: geekgardener: 691